user@linuxtrack:~ $ python -c 'print("Soyez les bienvenus !")'

Vous n'êtes pas identifié(e).

#1 14-05-2020 21:32:40

hydroviper
Membre

Problème avec imprimante réseau

Bonjour à tous et à toutes,

Ca faisait un moment que je n'étais pas venu sur le forum smile  J'étais sous Windows depuis que mon vieux portable a laché mais après 1 an de W10, j'ai capitulé et ai remis Linux en dual-boot…  Ce qui m'empêche de supprimer Windows, c'est ce problème.

Je tourne autour depuis plusieurs semaines en vain…

Je cherche à installer une imprimante Brother HL-1110 sur une Ubuntu Gnôme 20.05 via dnssd://bbox%20Ippos%20Printer._ipp._tcp.local/
Voici ce que j'ai fait :
télécharger sur Brother, le pilote LPR et le Cupwrapper (la 1110 est reconnue d'origine mais ça n'imprime pas…). Même résultat avec ces deux drivers…


On le voit, la box est visible depuis la Bbox :
mini_2005140936025167.png

Et reconnue depuis Ubuntu :
mini_200514093602255401.png

Et quand je cherche à imprimer, ça me mets ça :
mini_200514094200548916.png

Évidemment, ça n'a rien imprimé…
Quelqu'un peut m'aider svp ?
Merci beaucoup smile


W 3.1 > W XP > W Vista > Knoppix > Kaella > Debian > OpenSuse > Ubuntu > LinuxMint > Debian > Viperr > BunsenLabs > Manjaro > Debian / W 10 > W 10 > Ubuntu / W 10

Hors ligne

#2 14-05-2020 21:39:42

IceF0x
#! Gourou Linux

Re : Problème avec imprimante réseau

Que répond la commande id ? tu es dans le group lpadmin ?
En root elle fonctionne ?

PS: est-tu sur de ne pas imprimer dans un fichier au lieu de sur l'imprimante ?


Utiliser des logiciels propriétaires, c'est comme les plats préparés, on est incapable de dire les conservateurs qu'ils contiennent, on dira toujours que c'est bon, mais ça ne remplacera jamais le repas fait maison par sa maman.
]:D #! Crunchbang & Archlinux GNU/Linux User ]:D

Hors ligne

#3 14-05-2020 21:49:59

hydroviper
Membre

Re : Problème avec imprimante réseau

Salut IceF0x smile

Pour lpadmin : L'utilisateur appartient déjà au groupe « lpadmin »
Oui, j'imprime bien sur l'imprimante et pas dans un fichier.
Ça ne donne rien en root.

Je ne sais pas si ça peut aider :
mini_200514100532285187.png

Dernière modification par hydroviper (15-05-2020 12:05:00)


W 3.1 > W XP > W Vista > Knoppix > Kaella > Debian > OpenSuse > Ubuntu > LinuxMint > Debian > Viperr > BunsenLabs > Manjaro > Debian / W 10 > W 10 > Ubuntu / W 10

Hors ligne

#4 14-05-2020 22:12:01

IceF0x
#! Gourou Linux

Re : Problème avec imprimante réseau

essaye ceci

apt install cups-filters

et redémarre le service cups (ou le pc si tu veux pas te casser la tête.)


Utiliser des logiciels propriétaires, c'est comme les plats préparés, on est incapable de dire les conservateurs qu'ils contiennent, on dira toujours que c'est bon, mais ça ne remplacera jamais le repas fait maison par sa maman.
]:D #! Crunchbang & Archlinux GNU/Linux User ]:D

Hors ligne

#5 14-05-2020 22:19:33

hydroviper
Membre

Re : Problème avec imprimante réseau

Le terminal me dit ceci : cups-filters est déjà la version la plus récente (1.27.4-1).

Si j'utilise le driver fournit par Ubuntu, quand j'essaye d'imprimer, j'ai
cups ipp missing validate job
qui apparait dans la boite de dialogue. Je ne sais pas si ça fait avancer le schmiblick…

Et si je fais via http://bbox:631  j'ai le même problème.

Voici ce que me mets Cups quand j'imprime et qu'il me met « impression terminée » dans le petit popup
en cours d'impression depuis
jeu. 14 mai 2020 23:17:37
"Use "pdftops-renderer" option (see cups-filters README file) to use Ghostscript or MuPDF for the PDF -> PostScript conversion."

Dernière modification par hydroviper (14-05-2020 23:19:22)


W 3.1 > W XP > W Vista > Knoppix > Kaella > Debian > OpenSuse > Ubuntu > LinuxMint > Debian > Viperr > BunsenLabs > Manjaro > Debian / W 10 > W 10 > Ubuntu / W 10

Hors ligne

#6 15-05-2020 08:26:35

IceF0x
#! Gourou Linux

Re : Problème avec imprimante réseau

hydroviper a écrit :

Le terminal me dit ceci : cups-filters est déjà la version la plus récente (1.27.4-1).

Si j'utilise le driver fournit par Ubuntu, quand j'essaye d'imprimer, j'ai
cups ipp missing validate job
qui apparait dans la boite de dialogue. Je ne sais pas si ça fait avancer le schmiblick…

Et si je fais via http://bbox:631  j'ai le même problème.

Voici ce que me mets Cups quand j'imprime et qu'il me met « impression terminée » dans le petit popup
en cours d'impression depuis
jeu. 14 mai 2020 23:17:37
"Use "pdftops-renderer" option (see cups-filters README file) to use Ghostscript or MuPDF for the PDF -> PostScript conversion."

Et si tu utilise le .deb du site brother plutôt ?


Utiliser des logiciels propriétaires, c'est comme les plats préparés, on est incapable de dire les conservateurs qu'ils contiennent, on dira toujours que c'est bon, mais ça ne remplacera jamais le repas fait maison par sa maman.
]:D #! Crunchbang & Archlinux GNU/Linux User ]:D

Hors ligne

#7 15-05-2020 09:32:40

arno
Membre

Re : Problème avec imprimante réseau

Mon ordi tourne sous Debian (BL Hydrogen); j'ai aussi une imprimante/scanner Brother; et, bien que je ne saurais plus décrire comment j'ai fait pour finir par réussir à l'installer, je me rappelle avoir téléchargé les .deb sur le site de Brother (comme le conseil IceF0x).

J'ai un fichier "pense-bête" dans lequel je note des trucs qui m'ont "sauvé" (!). Et j'ai ça (mais c'est très bizarre.... car ça correspond à l'installation d'une imprimante canon...? mais si je l'ai noté c'est probablement car ça m'a été utile ! donc je note des trucs utiles.... mais sans me rappeler pourquoi ils l'ont été :-) ) voilà ce que ça donne:

## Installation imprimante/scanner brother
suivre cette démarche:

Open a terminal window and run lsusb. Here's what my output looked like. Yours should be similar.

UserName@computer ~ $ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 04b8:0131 Seiko Epson Corp.
Bus 001 Device 005: ID 04a9:1746 Canon, Inc.
Bus 001 Device 006: ID 050d:0234 Belkin Components F5U234 USB 2.0 4-Port Hub
Bus 002 Device 002: ID 046d:c018 Logitech, Inc. Optical Wheel Mouse
Bus 003 Device 002: ID 13ba:0017 Unknown PS/2 Keyboard+Mouse Adapter

Note the line that mentions a Canon device. If you see this line, then your computer knows that a Canon device is there and you are connected to it. You will need the "04a9:1746" information in the next step. Copy it or write it down.

Now, you will probably have to edit a system file called "60-libsane.rules" in order to tell your system that you have a Canon MP280 Scanner at the location you copied from the lsusb output. In my case, there was no mention of this exact device in the file, and I had to add it.

The file to edit is: /lib/udev/rules.d/60-libsane.rules

I used Nautilus to navigate to the system area and opened the folder /lib/udev/rules.d by right-clicking on it and selecting "Open as administrator" from the drop down menu. Then find the file 60-libsane.rules, double-click it to open it in a gedit text editor window. There's a long list of printers. There was no mention of the MP280 in my copy of this file. I scrolled down and copied the two lines for the PIXMA 270, opened up a space, and pasted them in. Then I edited the line to look like the two lines below that refer to the PIXMA 280. In my case, only the name of the device and the number "1746" had to be edited. Those four digits make a big difference.


Bon, voilà, au cas où ça peut aider !
Bonne journée

Hors ligne

#8 15-05-2020 12:04:22

hydroviper
Membre

Re : Problème avec imprimante réseau

Bonjour,
Merci de votre aide smile

Alors le message impression vient quand j'utilise le .deb cupwrapper du site Brother.
Le .deb LPR n'apparait pas quand on passe par l'interface, par contre son PPD est bien présent dans opt/
Si je choisi le .ppd, ça donne le même résultat.

Si j'utilise le pilote fournit par défaut par Ubuntu, qui utiliser brlaser v6 ( rv:///brlaser.drv/br1110.ppd) j'ai les messages, en USB direct ça fonctionne, mais en réseau, ça génère « traitement en cours » sans fin.

Pour lsusb, voici ce que ça donne en USB direct :


user@computer:~$ lsusb
Bus 001 Device 004: ID 8087:0aa7 Intel Corp.
Bus 001 Device 003: ID 0000:0538 
Bus 001 Device 002: ID 0438:7900 Advanced Micro Devices, Inc. Root Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 004: ID 04f9:0054 Brother Industries, Ltd HL-1110 series
Bus 002 Device 002: ID 05c8:0233 Cheng Uei Precision Industry Co., Ltd (Foxlink) HP Webcam
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

et quand je la mets en réseau :
user@computer:~$ lsusb
Bus 001 Device 004: ID 8087:0aa7 Intel Corp.
Bus 001 Device 003: ID 0000:0538 
Bus 001 Device 002: ID 0438:7900 Advanced Micro Devices, Inc. Root Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 002: ID 05c8:0233 Cheng Uei Precision Industry Co., Ltd (Foxlink) HP Webcam
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


W 3.1 > W XP > W Vista > Knoppix > Kaella > Debian > OpenSuse > Ubuntu > LinuxMint > Debian > Viperr > BunsenLabs > Manjaro > Debian / W 10 > W 10 > Ubuntu / W 10

Hors ligne

#9 15-05-2020 12:23:48

IceF0x
#! Gourou Linux

Re : Problème avec imprimante réseau

hydroviper a écrit :

Si j'utilise le pilote fournit par défaut par Ubuntu, qui utiliser brlaser v6 ( rv:///brlaser.drv/br1110.ppd) j'ai les messages, en USB direct ça fonctionne, mais en réseau, ça génère « traitement en cours » sans fin.

tu as installé l'imprimante via l'auto détection réseau ?


Utiliser des logiciels propriétaires, c'est comme les plats préparés, on est incapable de dire les conservateurs qu'ils contiennent, on dira toujours que c'est bon, mais ça ne remplacera jamais le repas fait maison par sa maman.
]:D #! Crunchbang & Archlinux GNU/Linux User ]:D

Hors ligne

#10 15-05-2020 13:42:41

hydroviper
Membre

Re : Problème avec imprimante réseau

Oui, via l'auto détection réseau.


W 3.1 > W XP > W Vista > Knoppix > Kaella > Debian > OpenSuse > Ubuntu > LinuxMint > Debian > Viperr > BunsenLabs > Manjaro > Debian / W 10 > W 10 > Ubuntu / W 10

Hors ligne

#11 15-05-2020 14:55:54

IceF0x
#! Gourou Linux

Re : Problème avec imprimante réseau

hydroviper a écrit :

Oui, via l'auto détection réseau.

bizarre que ça marche pas et direct en USB, je sèche.


Utiliser des logiciels propriétaires, c'est comme les plats préparés, on est incapable de dire les conservateurs qu'ils contiennent, on dira toujours que c'est bon, mais ça ne remplacera jamais le repas fait maison par sa maman.
]:D #! Crunchbang & Archlinux GNU/Linux User ]:D

Hors ligne

#12 15-05-2020 15:11:35

hydroviper
Membre

Re : Problème avec imprimante réseau

Oui, c'est bizarre en effet, surtout avec la détection auto et le pilote qui fonctionne en USB, je ne comprends pas ce qui peut bloquer non plus…

Bon, comme c'est un portable et que je n'imprime pas tous les jours, j'ai le choix entre le déplacer près de l'imprimante ou garder le dual boot juste pour rester à ma place…  siffle


W 3.1 > W XP > W Vista > Knoppix > Kaella > Debian > OpenSuse > Ubuntu > LinuxMint > Debian > Viperr > BunsenLabs > Manjaro > Debian / W 10 > W 10 > Ubuntu / W 10

Hors ligne

#13 16-05-2020 08:09:49

IceF0x
#! Gourou Linux

Re : Problème avec imprimante réseau

Malheureusement j'ai une HP donc je connais mieux les soucis avec HP tu sais ping ton imprimante sans problème ?


Utiliser des logiciels propriétaires, c'est comme les plats préparés, on est incapable de dire les conservateurs qu'ils contiennent, on dira toujours que c'est bon, mais ça ne remplacera jamais le repas fait maison par sa maman.
]:D #! Crunchbang & Archlinux GNU/Linux User ]:D

Hors ligne

#14 16-05-2020 21:38:25

hydroviper
Membre

Re : Problème avec imprimante réseau

Si on y arrive, tant mieux, sinon tant pis wink

Voici le résultat du ping (j'ai pris l'IP donné par l'auto détection réseau)

--- 192.168.1.254 ping statistics ---
114 packets transmitted, 114 received, 0% packet loss, time 113165ms
rtt min/avg/max/mdev = 2.622/4.119/111.350/10.090 ms


W 3.1 > W XP > W Vista > Knoppix > Kaella > Debian > OpenSuse > Ubuntu > LinuxMint > Debian > Viperr > BunsenLabs > Manjaro > Debian / W 10 > W 10 > Ubuntu / W 10

Hors ligne

#15 17-05-2020 11:06:41

IceF0x
#! Gourou Linux

Re : Problème avec imprimante réseau

hydroviper a écrit :

Si on y arrive, tant mieux, sinon tant pis wink

Voici le résultat du ping (j'ai pris l'IP donné par l'auto détection réseau)

--- 192.168.1.254 ping statistics ---
114 packets transmitted, 114 received, 0% packet loss, time 113165ms
rtt min/avg/max/mdev = 2.622/4.119/111.350/10.090 ms

C'est bon pourtant, tu sélectionen bien l'imprimante réseau au moment d'imprimer et pas celle en USB ?


Utiliser des logiciels propriétaires, c'est comme les plats préparés, on est incapable de dire les conservateurs qu'ils contiennent, on dira toujours que c'est bon, mais ça ne remplacera jamais le repas fait maison par sa maman.
]:D #! Crunchbang & Archlinux GNU/Linux User ]:D

Hors ligne

#16 17-05-2020 13:58:49

hydroviper
Membre

Re : Problème avec imprimante réseau

Oui, j'ai mis deux noms bien distincts pour ne pas faire d'erreur.


W 3.1 > W XP > W Vista > Knoppix > Kaella > Debian > OpenSuse > Ubuntu > LinuxMint > Debian > Viperr > BunsenLabs > Manjaro > Debian / W 10 > W 10 > Ubuntu / W 10

Hors ligne

Pied de page des forums