user@linuxtrack:~ $ python -c 'print("Soyez les bienvenus !")'

Vous n'êtes pas identifié(e).

#1 15-07-2015 21:47:13

WangXiangzhai
Membre

[astuce] problème de son Xfce4 Debian 8.1 et HandyLinux. 8.1

et oui je suis passé à Xfce, depuis Jessie j'ai vraiment plus le spirit pour Gnome !

testé avec une:

root@debian:/home/philippe# lspci | grep -i audio
00:05.0 Audio device: NVIDIA Corporation MCP61 High Definition Audio (rev a2)
root@debian:/home/philippe# 

le problème se présentait ainsi.

1436989693.png

tout dé-muté, mais pas de son.

j'ai eu le problème sur les deux simultanément.

pour régler mes problèmes de son sur Debian Xfce et HandyLinux. 8.1.

j'ai installé pavucontrol

# apt-get install pavucontrol

lancer:

menu >multimédia>contrôle du volume pulseaudio

onglet > périphériques de sortie

1436989530.png

décocher le petit bouton.

pour moi ça à marché  wink

@+

Dernière modification par WangXiangzhai (16-07-2015 08:58:52)


PC: HP-pavilion a6227.fr | wifi: Awus036H et HWGUSB2-54 | CG: NVIDIA geforce 8400 GS | OS: Debian-8.1.0-i386 Xfce | EN TESTE kali-linux-openbox-rolling-i386.iso (KaliBang), bento-openbox-14.04.3-i386.iso et Viperr8_i686.iso

Hors ligne

#2 16-07-2015 09:49:37

enebre
Membre

Re : [astuce] problème de son Xfce4 Debian 8.1 et HandyLinux. 8.1

Bonjour,
J'ai également un petit soucis avec le son.
Malgré le changement demandé dans Pavucontrol.
A chaque redémarrage je retrouve le son en HDMI, alors que je préfèrerais qu'il reste sur mes HP extérieurs  en Duplex Stéréo Analogique.

Existe-t-il un fichier à modifier ou le changement serait permanent ?
merci


debian 8 x

Hors ligne

#3 16-07-2015 14:05:22

WangXiangzhai
Membre

Re : [astuce] problème de son Xfce4 Debian 8.1 et HandyLinux. 8.1

regardes ici c'est pour gnome, mais ça devrait marcher pour xfce.

n' hésites pas à faire un autre sujet, je suis pas un spécialiste du son.

@+

Dernière modification par WangXiangzhai (16-07-2015 14:09:50)


PC: HP-pavilion a6227.fr | wifi: Awus036H et HWGUSB2-54 | CG: NVIDIA geforce 8400 GS | OS: Debian-8.1.0-i386 Xfce | EN TESTE kali-linux-openbox-rolling-i386.iso (KaliBang), bento-openbox-14.04.3-i386.iso et Viperr8_i686.iso

Hors ligne

#4 16-07-2015 14:49:07

Caly
Membre indécis

Re : [astuce] problème de son Xfce4 Debian 8.1 et HandyLinux. 8.1

Juste pour savoir, tu pourrais nous copier/coller cat /proc/asound/cards stp ?


Lenovo Ideapad Yoga 510-14isk | Windows 10 ;  Debian 9 | Intel Core i5 6200U | 8go RAM | SSD 256Go

Hors ligne

#5 16-07-2015 15:31:51

IceF0x
#! Gourou Linux

Re : [astuce] problème de son Xfce4 Debian 8.1 et HandyLinux. 8.1

enebre a écrit :

Bonjour,
J'ai également un petit soucis avec le son.
Malgré le changement demandé dans Pavucontrol.
A chaque redémarrage je retrouve le son en HDMI, alors que je préfèrerais qu'il reste sur mes HP extérieurs  en Duplex Stéréo Analogique.

Existe-t-il un fichier à modifier ou le changement serait permanent ?
merci

Je me demande si la solution ne se trouve pas sur le forum handylinux, je ferai une recherche à mon retour de vacances si tu ne la retrouve pas.

Edit: regarde ce topic http://forum.handylinux.org/viewtopic.php?id=549


Utiliser des logiciels propriétaires, c'est comme les plats préparés, on est incapable de dire les conservateurs qu'ils contiennent, on dira toujours que c'est bon, mais ça ne remplacera jamais le repas fait maison par sa maman.
]:D #! Crunchbang & Archlinux GNU/Linux User ]:D

En ligne

#6 16-07-2015 15:42:30

enebre
Membre

Re : [astuce] problème de son Xfce4 Debian 8.1 et HandyLinux. 8.1

merci merci pour vos réponses,

WangXiangzhai, je vais plancher sur la question en étudiant la solution proposée par ton lien, à première vue ça me semble assez ardu, mais je vais m'y coller un matin, le cerveau bien reposé.
Caly, voici le retour à la commande :

[== Indéfini ==]
@debian:~$ cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xc7400000 irq 45

IceF0x, je vais y aller faire une recherche, merci


debian 8 x

Hors ligne

#7 17-07-2015 00:12:37

enebre
Membre

Re : [astuce] problème de son Xfce4 Debian 8.1 et HandyLinux. 8.1

WangXiangzhai, Bonsoir, Le problème est résolu grace à ton lien merci  tongue


debian 8 x

Hors ligne

#8 17-07-2015 00:28:25

enebre
Membre

Re : [astuce] problème de son Xfce4 Debian 8.1 et HandyLinux. 8.1

WangXiangzhai,  j'ai essayé la méthode proposée , mais au reboot ça me retourne une erreur de pulseaudio.
Je me demandais si c'était correct, je vois deux adressages différents dans les commandes pour default.pa.

cp /etc/pulse/default.pa ~/.config/pulse/default.pa
echo 'set-card-profile alsa_card.pci-0000_00_1b.0 output:analog-stereo' >> ~/.pulse/default.pa

qu'en pensez-vous ?


debian 8 x

Hors ligne

#9 17-07-2015 21:10:04

WangXiangzhai
Membre

Re : [astuce] problème de son Xfce4 Debian 8.1 et HandyLinux. 8.1

@ enebre

on s'inspire d'un tuto, mais on ne l'applique jamais à la lettre aveuglément sans le comprendre.

la première commande cp, t'indique de copier, coller simplement

/etc/pulse/default.pa

dans ton

/home/ton_user/.config

ce qui doit donner /home/ton_user/.config/pulse/default.pa

un /.fichier est un fichier caché (point + /fichier)

donc afficher, montrer les fichiers cachés dans le gestionnaire de fichiers (pour voir le résultat).

aussi: cd et ls -a

parce que:

Attention: PulseAudio cherche sa configuration dans cet ordre, d’abord le fichier dans le HOME puis le fichier par défaut si le précédent n’existe pas. Si il trouve un fichier de configuration dans le HOME de l’utilisateur, il le charge et ne charge pas celui par défaut. Le fichier du home doit donc contenir l’ensemble des instructions nécessaire à la recherche des cartes audio et à la bonne configuration.

la commande echo

c'est pour écrire une ligne dans le fichier /home/ton_user/.config/pulse/default.pa

ce qui peut être réalise aussi directement avec l'utilitaire pacmd.

tout ça tu peux le faire aussi à la main si tu veux, avec nano ou mousepad !

je te le redis tu t'ecartes beaucoup de mon sujet et de mon champs de compétences.

@+

Dernière modification par WangXiangzhai (17-07-2015 21:46:39)


PC: HP-pavilion a6227.fr | wifi: Awus036H et HWGUSB2-54 | CG: NVIDIA geforce 8400 GS | OS: Debian-8.1.0-i386 Xfce | EN TESTE kali-linux-openbox-rolling-i386.iso (KaliBang), bento-openbox-14.04.3-i386.iso et Viperr8_i686.iso

Hors ligne

#10 17-07-2015 22:50:28

enebre
Membre

Re : [astuce] problème de son Xfce4 Debian 8.1 et HandyLinux. 8.1

Ok j'abandonne l'idée de changer le module HDMI par default, en fait si je veux rester très positif, il est même mieux de n'avoir que le son du système HDMI en standard et je switch manuellement le soir lors des moments de détentes à l'occasion d'un film ou pour une vidéo , et ça me fait de l'économie d'énergie .
En fait tout est bien sur ma debian 8 x à la sauce rodofr
Encore merci pour votre aide et patience.

Dernière modification par enebre (18-07-2015 08:41:03)


debian 8 x

Hors ligne

#11 17-07-2015 23:27:47

WangXiangzhai
Membre

Re : [astuce] problème de son Xfce4 Debian 8.1 et HandyLinux. 8.1

merci enebre? pour le lien Voyager X8, je vais tester.

dès que sourceforge.net ne sera plus 404.

ps: après sauvegarde bien sur !

un petit truc, que j'ai voulu tester quand même c'est:

supprimer /etc/pulse/default.pa

pour voir si mon /home/philippe/.config/pulse pouvait faire l'affaire (reprendre le truc comme dans la doc) ?

effectué 2 reboot (/etc/pulse/default.pa n'est pas re-crée).

j'ai toujours mon son.

et des fichiers en plus dans /home/philippe/.config/pulse

1437176331.png

y a un truc à creuser la dedans quand même !

@+

Dernière modification par WangXiangzhai (18-07-2015 01:41:39)


PC: HP-pavilion a6227.fr | wifi: Awus036H et HWGUSB2-54 | CG: NVIDIA geforce 8400 GS | OS: Debian-8.1.0-i386 Xfce | EN TESTE kali-linux-openbox-rolling-i386.iso (KaliBang), bento-openbox-14.04.3-i386.iso et Viperr8_i686.iso

Hors ligne

#12 18-07-2015 08:44:31

enebre
Membre

Re : [astuce] problème de son Xfce4 Debian 8.1 et HandyLinux. 8.1

Je crois aussi  qu'il manque une petite explication pour le son et adaptée à xfce pour debian 8.1.
Bonne découverte avec la Voyager debian 8 X


debian 8 x

Hors ligne

#13 18-07-2015 21:31:39

WangXiangzhai
Membre

Re : [astuce] problème de son Xfce4 Debian 8.1 et HandyLinux. 8.1

j'ai  wink

1437247835.png


PC: HP-pavilion a6227.fr | wifi: Awus036H et HWGUSB2-54 | CG: NVIDIA geforce 8400 GS | OS: Debian-8.1.0-i386 Xfce | EN TESTE kali-linux-openbox-rolling-i386.iso (KaliBang), bento-openbox-14.04.3-i386.iso et Viperr8_i686.iso

Hors ligne

#14 18-07-2015 21:55:23

enebre
Membre

Re : [astuce] problème de son Xfce4 Debian 8.1 et HandyLinux. 8.1

Belle comme un canon cette "Voyager"


debian 8 x

Hors ligne

#15 02-09-2015 12:14:14

apapillon
Membre

Re : [astuce] problème de son Xfce4 Debian 8.1 et HandyLinux. 8.1

enebre a écrit :

WangXiangzhai,  j'ai essayé la méthode proposée , mais au reboot ça me retourne une erreur de pulseaudio.
Je me demandais si c'était correct, je vois deux adressages différents dans les commandes pour default.pa.

cp /etc/pulse/default.pa ~/.config/pulse/default.pa
echo 'set-card-profile alsa_card.pci-0000_00_1b.0 output:analog-stereo' >> ~/.pulse/default.pa

qu'en pensez-vous ?

Bonjour,
Je suis l'auteur du tuto en lien.

Si pulseaudio ne répond pas c'est que le fichier de config est mauvais.
Il faut prendre le fichier de base pour ajouter à la fin le choix de la carte voulue au démarrage.
Si vous ajoutez juste la carte dans le fichier, pulseaudio ne trouveras pas les paramètres de base.

J'espère apporter un peu d'eau au moulin.

@+

Hors ligne

#16 04-09-2015 16:19:22

enebre
Membre

Re : [astuce] problème de son Xfce4 Debian 8.1 et HandyLinux. 8.1

apapillon@ bonjour,

J'ai bien suivi ton excellent tuto et j'ai analog-stereo de sélectionné par defaut, malgré cela le son est désactivé dans Audio-mixer de ma debian-Jessie.

C'est déjà beaucoup mieux je n'ai qu'à activer l'icone des "speaker" dans audio-mixer et ça fonctionne  merci
1441376320.png


debian 8 x

Hors ligne

Pied de page des forums